android-acesso-root

Um dos principais desenvolvedores de apps para Android que dependem de root, conhecido como Chainfire, divulgou um alerta recente para a comunidade do sistema do Google. Segundo ele, é muito provável que a próxima atualização do Android quebrem vários aplicativos que dependem do acesso rooteado.

Ele aponta que as alterações de código na árvore mestra do Android Open Source Project deve impedir que o superusuário execute arquivos na pasta “/data”.

Chainfire deixa bem claro que não são todos os apps que serão afetados. “Muitos aplicativos incluem binários ou scripts extraídos para diretórios específicos localizados na partição “/data” e executam de lá”, explica, afirmando que esta funcionalidade não será mais permitida de forma nativa.

Contudo, ele aponta que há “certamente vários modos de contornar o problema para os apps afetados”, mas não parece haver uma solução genérica aplicável em todos os casos. Assim, os desenvolvedores irão precisar bolar suas próprias técnicas para driblar a situação.

Aparentemente, segundo ele, a próxima grande atualização do Android já deve contar com isso, seja ela a 4.4.3, 4.5 ou 5.0. O alerta feito por ele tem como objetivo avisar a comunidade o quanto antes, para que se prepare para as mudanças e se unam para pensar em uma forma de impedir que isso se torne um problema sério com o próximo update.

Via Phandroid